Denford Easiturn PNC3 - Motor Drive Fault X Axis

Information and questions about Denford CNC Control electronics, general electrical issues, cables, diagrams, stepper motors, drives etc...

Moderators: Martin, bradders, Steve, Mr Magoo

Post Reply
Olly
Posts: 2
Joined: Thu 06 Mar , 2014 20:20 pm
Hardware/Software: Easiturn 3 - PNC 3

Denford Easiturn PNC3 - Motor Drive Fault X Axis

Post by Olly » Fri 07 Mar , 2014 21:51 pm

Hi everyone, I've recently bought a Denford Easiturn 3 from the user on this forum named Ted from Norfolk. I believe he asked some questions about the Limit switches on the machine which I have now replaced.

Here is my problem - when I attempt to Datum the machine I get the message - Motor Drive Fault X

I have removed the cover from the control system to check the LED's on what i believe are the drivers, and on the left hand driver there is no green LED & only the Red LED in the centre is illuminated. On the right hand driver there is the green led illuminated as well as the red LED in the centre.

Has anyone experienced this fault before? or can anyone point me in the right direction to look for a solution to my problem?

I would be extremely grateful if anyone could help in any way.

Thanks
Olly

Martin
CNC Guru
CNC Guru
Posts: 1749
Joined: Fri 24 Feb , 2006 17:09 pm
Location: Brighouse

Re: Denford Easiturn PNC3 - Motor Drive Fault X Axis

Post by Martin » Tue 16 Apr , 2019 12:54 pm

Have you powered up the drive?

As I remeber it you need to release the E-Stop button & then power up the drives before you are able to home them.

Post Reply