Machine pauses at each point when machining

All info relating to the Denford MicroRouter Compact small routing machines

Moderators: Martin, bradders, Steve, Mr Magoo

Post Reply
AliveOak
Posts: 20
Joined: Fri 29 Aug , 2014 10:57 am
Hardware/Software: MicroRouter Compact (SN:H04459/1)
RS232 Cable
Dell PC + XP Pro
Next Step Control Card (Green LED)

Machine pauses at each point when machining

Post by AliveOak » Fri 29 Aug , 2014 11:20 am

Hi Guys. My first post here but I have read a lot of the forum for this machine. I am having a problem with my MicroRouter Compact. Can you help?

I am running V2.23 with Windows XP Pro on a Dell PC. The firmware is up to date (5216, FPGA 17 & CPLD 9) using Next Step on an NS control card (the newest one with the green LED) and all would seem to be good in terms of comms and control.

However, when the machine runs the GCode, it pauses for a quarter of a second at each point. It is as if it is a child learning to read... "The. Cat. Sat. On. The. Mat..." etc. It can't seem to read ahead and go smoothly from point to point. This not only slows the machine down but enables the tool to burn the timber.

When jogging, it works fine. When machining a G03 interpolated curve, it moves fine but when running a .fnc file from Cut3D, it pauses at each point. As you can imagine, it's quite frustrating. I have spent ages adjusting baud rates and all sorts of parameters to no effect. (Well, no positive effect anyway.)

Can anyone point me toward a specific setting that might be responsible for this please?

Many thanks in advance.

Pete

Martin
CNC Guru
CNC Guru
Posts: 1732
Joined: Fri 24 Feb , 2006 17:09 pm
Location: Brighouse

Re: Machine pauses at each point when machining

Post by Martin » Fri 29 Aug , 2014 18:15 pm

Make sure you are running in TURBO mode?

The button should be in the control panel window when you are in auto mode.

In the latest software we default TURBO to be on.

AliveOak
Posts: 20
Joined: Fri 29 Aug , 2014 10:57 am
Hardware/Software: MicroRouter Compact (SN:H04459/1)
RS232 Cable
Dell PC + XP Pro
Next Step Control Card (Green LED)

Re: Machine pauses at each point when machining

Post by AliveOak » Sat 30 Aug , 2014 14:53 pm

Thanks for getting back to me so soon Martin. I have been itching to get back to the shop and try it. Can it really be that simple?! I feel slightly foolish. :D

I went to the machine today and another gremlin has surfaced. When i try to connect to it, it erases the flash and then a box appears saying "Invalid Image Format". I've not seen this before and can't tell you what, if anything, I have done to generate this fault. Any ideas?

Thanks again Mr. Guru.

Martin
CNC Guru
CNC Guru
Posts: 1732
Joined: Fri 24 Feb , 2006 17:09 pm
Location: Brighouse

Re: Machine pauses at each point when machining

Post by Martin » Sat 30 Aug , 2014 18:05 pm

It may be worth updating VRMilling to version 2.31 which you can download FOC from the Denford website. Make sure you have a copy of the licence key first though.

AliveOak
Posts: 20
Joined: Fri 29 Aug , 2014 10:57 am
Hardware/Software: MicroRouter Compact (SN:H04459/1)
RS232 Cable
Dell PC + XP Pro
Next Step Control Card (Green LED)

Re: Machine pauses at each point when machining

Post by AliveOak » Sat 30 Aug , 2014 19:37 pm

I had done something to make the firmware revert to an older version so ran Easy Upgrader 2 and it connected straight away. I then uploaded a file, pressed the turbo button as you suggested, and she flies along!!

All sorted now Martin. Thanks very much indeed sir! 8)

Post Reply