
 

 

R6 F1 Car Tutorial 
Using the 223MM X 65MM X 50MM Balsa Blank 



 

 



 

 

Designing the F1 Car Tutorial 
Introduction 

 

 
How does this Tutorial Work? 
 
This tutorial is divided into three sections and concentrates on the DESIGN and MAKE 
portions of the F1 in Schools CAD/CAM Design Challenge. 
 
1) Designing the F1 Car in Pro/DESKTOP 8.0 
 ●  Start off with a template of an F1 car and follow along while you are guided 
 through the creation of a 3D model.  You will also get your chance at design 
 when you have the opportunity to create your own wings for the F1 car. This 
 section is also referred to as CAD (Computer Aided Design). 
 
2)   Creating the F1 Car file for Manufacture using QuickCAM 3D 
  ●  In this section, you will convert your STL file that was created in Pro/       

 DESKTOP, into a file that the machine will read to produce the final part.  This 
 sections is also referred to as CAM (Computer Aided Manufacturing). 

 
3)   Manufacturing the F1 Car 
 ●  Learn how to setup the F1 Car fixture, set machine offsets, and machine the 
 F1 Car. 
 

► ► 

CAD CNC CAM 



 

 

Designing the F1 Car Tutorial 
Instructors Notes 

 

 
1. Create a directory to store your Pro/DESKTOP template.  
2. Copy the R6 F1 Car Template.des file from the CD into the newly 

created folder. 
3. The tutorial is written in metric so you will need to ensure that 

Pro/DESKTOP is configured correctly. To do this, select the Tools 
drop down menu, then select Options, then select Units and set 
both Model distances and Paper distances to mm. 

4. The student will be asked to save his/her work, please provide 
them with a location to do this. 

5. We recommend the instructor works through this tutorial before 
issuing it to the students, to insure you have a full understanding 
of what is required. 
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Unit 1 Designing the Car 
Task 1 Creating the Fuel Pods 

1.1 

1) Open the file named R6 F1 Car  
      Template.des   
 
      To do this, from the menu bar, click 

File> Open. Select the R6 F1 Car  
 Template.des file from the location 

defined by your instructor, and click 
Open. Your screen should look simi-
lar to the one shown in Figure 1. 

 
2) Maximize the window by clicking the 

square at the upper right corner of 
the screen. Then zoom to view the 
full template in Figure 2. 

 

3) In the Object Browser, click the + 
symbol next to each Workplane 
folder to display the sketches that 
you will be using. 

 
  
 
  
 

Figure 1 - The R6 F1 Car Template.des file 

Figure 2 - The Car Template View 

Helpful Hints: 
 
• To Rotate: Use the center mouse 

button 
• To Pan: Hold down the Shift Key 

and the Center mouse button. 
• To Zoom: Hold down the Ctrl Key 

and the Center mouse button. 

Open Pro/DESKTOP V8. Check to make sure that you are using metric.  To do this go to the 
Tools drop down menu and select Options, then select Units. 



 

 

Unit 1 Designing the Car 
Task 1 Creating the Fuel Pods 

1.2 

4) From the menu bar, click Feature 
> Extrude Profile.  

 
5) Enter the following information in   

the Extrude Profile window. 
 
• Feature name: Fuel Pod Extrusion 
• Sketch to use as profile: Fuel Pod 
• Select - Add material 
• Type 32.5 for the Distance 
• Select - Above workplane 
• Click OK  
 
6) Your screen should now look like 

the model in Figure 4. 
 
7)  Left mouse click to accept. 

Figure 3 - Extrude Profile Window 

Figure 4 - Right Fuel Pod Extruded 

Helpful Hint:  When you are either Extruding a Profile or Projecting a Profile, you will notice a 
green arrow and a yellow arrow next to the vectors that you are trying to Extrude or Project. The 
green arrow represents the direction you will be Extruding or Projecting either above, below or 
symmetric about the workplane. The yellow arrow represents the area you will be adding or sub-
tracting. 
 
For example, on the fuel pod, the green arrow is pointing away from the center of the car, this 
represents adding material above the workplane. The yellow arrow is pointed towards the center 
of the fuel pod. This represents the area inside the fuel pod will be Extruded. 



 

 

Unit 1 Designing the Car 
Task 1 Creating the Fuel Pods 

1.3 

      You are now going to shape the 
Fuel Pod by subtracting the profile  
sketch from the Fuel Pod feature. 

 
8) From the menu bar, click  
 Feature > Project Profile.  
 
9)   Enter the following information in 

the Project Profile window.  
• Feature name: Fuel Pod  
      Projection 
• Sketch to use as profile: Fuel Pod    

Bottom View 
• Select - Subtract material 
• Select - Above workplane 
• Select - Thru to next face 
• Click OK  
 
10) Left mouse click to accept. 
 
 
 
    
 

Figure 5- The Fuel Pod  Projection Feature. 

Figure 6- The Fuel Pod  rendered. 



 

 

Unit 1 Designing the Car 
Task 1 Creating the Fuel Pods 

1.4 

8)   You will now mirror the Fuel Pod 
that you have just created around 
Workplane 5. Go to Feature> 
Modify Solids> Mirror Solids. 

 
9) In the Mirror Solids window, 

change the Feature Name to Fuel 
Pod and make sure Keep original 
solid is checked. Left Click on 
Workplane 5. (This is to select the 
mirror plan) Your model should 
now look like the one in Figure 7. 
Press OK. 

 
10) Left mouse click to accept. 
 
11) You have now completed Task 1   

Creating the Fuels Pods. Go to 
File> Save Copy As> Now save 
the file as a unique name. 

 Example: Coree F1 Car.  
      Click on Save. 
 
12) Now that you have saved a copy, 

go to File> Close. (This is to pre-
vent the software from overwriting 
the template file.) Go to File > 
Open, and select the file that you 
just saved. Click Open.  Your file 
name should now appear at the 
top left of the screen. You are now 
ready to move onto Task 2.  

Figure 7 - Mirrored Fuel Pod Preview 

Figure 8 - Mirrored Fuel Pod 

Figure 9 - Check title screen 



 

 

Unit 1 Designing the Car 
Task 2  Creating the Main Body Profile 

1.5 

1) In the Object Browser, click the 
+ symbol next to each Work-
plane folder to display the 
sketches that you will be using. 

 
2) With the new file open, From 

the Menu bar, click  
 Feature> Loft Through  
 Profiles.   
 
3)   Select Main Body Profile 1 from 

Workplane 1 in the Object 
Browser. 

 
4)   Repeat step 3 for Main Body 

Profile 2, 3, and 4. See Figure 
11. 

 
5)   Make sure the following are se-

lected in the Loft Profiles Win-
dow: 

• Feature Name: Main Body  
      Profile 
• Add Material is Selected 
             
6)   Click OK. 
 
 
 
 
 
 
 
 

Figure 10 - Lofting Main Body Profiles . 

Figure 11 - All 4 Main Body Profiles Selected. 



 

 

Unit 1 Designing the Car 
Task 2 Creating the Main Body Profile 

1.6 

7)   You have now created the Main 
Body Profile and Task 2 is com-
plete. 

 
8)   Go to File> Save.  
 
 
 
 
 
 
 
 
 
 
 
 

Figure 12 - Main Body Profile completed. 



 

 

Unit 1 Designing the Car 
Task 3 Front End Cut Out 

1.7 

      By using the Project Profile Tool, 
you will now create the Front End 
Cut Out. 

 
1)   Go to Feature> Project Profile. 
 
2) Enter the following information in 

the Project Profile window. 
• Feature Name: Front End Cut Out 
• Sketch to use as profile: Front End 

Cut Out 
• Select - Subtract material 
• Select - Symmetric about the 

workplane 
• Select - Thru entire part 
      Click OK  
 
3) Your model should now look like 

the one in figure 14. 
 
4) Left mouse click to accept. 
 
4)   Task 3 is complete and you may 

now save your Car file. 

Figure 13 - Project Profile Window for Front End Cut Out. 

Figure 14 - Updated front end 



 

 

Unit 1 Designing the Car 
Task 3 Creating the Front Axle Supports 

1.8 

1)   From the top menu select View > 
Go To > Isometric View. 

 
2)   From the top menu select Feature 

> Extrude Profile. 
 
4) In the Extrude Profile window, set 

the following:  
• Feature Name: Front Axle Sup-

ports 
• Sketch to Use as Profile: Front 

Axle Supports 
• Select - Add Material. 
• Change the Distance to 45. 
• Select - Symmetric About  Work-

plane. 
• Your screen should look like the 

one shown in Figure 15. Click OK. 
 
5)  Left mouse click to accept. 
 
6)   The third task is now complete. 

You can now save your file. 
 
       
 
      Helpful Hint: 
      You may also change the distance 

on a extruded object by holding 
down the left mouse button on the 
center of the yellow square and 
drag the mouse to the desired 
distance on screen.  

      (Refer to Figure 16.) 

Figure 15 - Creation of the Front Axle Support. 

Figure 16 - Manual Extrusion 



 

 

Unit 1 Designing the Car 
Task 4 Creating the Front Wing 

1.9 

1) In this task, you will start by cre-
ating the shape of the wing, 
then extruding it. This task is 
different than previous tasks, 
because you are going to first 
create you own design. 

 
2) Right Click on Workplane 5 and        

select new sketch. Change the 
sketch name to “Front Wing” 
and click OK 

 
3) From the View menu select Go 

To> Onto Workplane.  Using 
the mouse, zoom in on the front 
of the car.      

 
4) You will now use the line tool to 

create the profile of the front 
wing. 

 
5) From the Line menu select        

Straight. To create a line, move 
the cursor to the position you 
want to start your line and hold 
down the left mouse button.  
While pressing the mouse but-
ton, drag the mouse to the de-
sired location for your line. To 
create a straight line, simply 
hold down the shift button while 
you create the line. 

 
6) Using the line tool, create a side 

view of the front wing. Figure 19 
shows you an example of one.  

 
 

Figure 18 - Up close look of front end 

Figure 19 - Front Wing Shape 

Figure 17 - New Sketch 
window 



 

 

Unit 1 Designing the Car 
Task 4 Creating the Front Wing 

1.10 

7) Next, select the Arc tool from 
the Line menu and create a few  

      fillets on your wing. Refer to Fig 
20 on creating fillets.  Fillets are 
another term for radius.  

 
 Helpful Hint: Position the cursor 

so it intersects the two lines.  
Ensure the lines are pre-
selected (blue) before dragging 
the mouse away.  

  
 If the sketch is not shaded, it is 

not valid. Use the undo key or 
delete the lines and start again. 

 
8) Once you have created some 

fillets on your wing, you are now 
ready to extrude it. 

 
9) Change your view to Isometric.  

From the View menu, select Go 
To, Isometric.  

 
10) From the Feature menu, select    

Extrude Profile.  
 
11) Enter the following information in   

the Extrude Profile window. 
 
• Feature name: Front Wing 
 Extrusion 
• Sketch to use as profile: Front 

Wing 
• Select - Add material 
• Distance: Refer to the rules to 

make sure your wing conforms 
to the regulations, with regard to 
the maximum width and length.  

• Select - Symmetric about  
      workplane 
• Click OK  
 
12) You have now created the     

front wing.  You can now save 
your file. 

Figure 21 - Front Wing Design 

Figure 22 - Front Wing Extrusion 

Figure 20 - Creating a fillet 



 

 

Unit 1 Designing the Car 
Task 5 Creating the Rear Wing 

1.11 

1) You will now create the Rear 
wing just like you created the 
front wing, so start off by right 
clicking on Workplane 5 and 
selecting New Sketch. 

 
2) Change the name to “Rear 

Wing” and click OK. 
 
3) Using what you learned in Task  

4, create the rear wing.  Re-
member to ensure the sketch is 
valid (shaded) before extruding.  
Also keep in mind to pay atten-
tion to the rules with regard to 
wing dimensions. 

 
4) The Balsa Blank is 50 MM high, 

so when you are creating the 
vectors, refer to the coordinates 
to make sure you don’t exceed 
the boundaries of the Blank.  In 
Figure 23 the Blue circle is high-
lighting the origin, and the Red 
circle is highlighting your coordi-
nates of the cursor. 

 
4) Once you have designed your 

wing, you can now use the  
      Extrude tool, keeping in mind 

the Balsa Blank is 65 MM wide. 
 
5) Task 5 in now complete and you 

can now save your model. 
 
 

Figure 23 - Drawing Coordinates 

Figure 24 - Rear Wing Extrusion 



 

 

Unit 1 Designing the Car 
Task 6 Exporting Stereo Lithography  Files 

1.12 

Figure 25- The Completed F1 Car 

Figure 26 - The Export Stereo Lithography window. 

Congratulations! You have now completed the  
Designing the Car in Pro/DESKTOP F1 Car Tutorial. 

1)  From the menu bar click File > 
Export > Stereo Lithography  
File. 

 
 Stereo Lithography (STL) is a 3D 

surface map of the model defined 
by triangles.  The STL format is 
the universal transfer file for 3D 
models. 

 
2) A window will appear as shown in 

Figure 26. Click Browse and 
change the path to a specified  
location, given by your instructor. 

  
3) Select the ASCII Output mode. 

Binary Output mode can also be 
selected if you wish to create a 
smaller file size. 

 
4) Set the Chordal tolerance to 0.1 
 
5) Click OK. The software will create 

an STL file for your car model 
which will be used later in  

 QuickCAM 3D. 
 
 
 



 

 

QuickCAM 3D F1 Car Tutorial 



 

 



 

 

Unit 2 QuickCAM 3DV3 F1 Tutorial 

2.1 

      Make sure you have the Quick-
CAM 3D Wizard open on your 
screen. 

 
1)   Setting Units of Measurement 
• From the menu bar, click  
      Options > Units. 
• A check mark should be shown 

before Metric.  If necessary, 
change to Metric units by clicking 
the Metric option. 

 
 
      Please note.. Your model may 

vary to the model shown in the 
following figures. 

 
 
 
2)   OPEN MODEL PAGE 
• Click the 3D Model button. 
• Locate the  STL file you created 

earlier and Click Open. 
• You can rotate and zoom on the 

model using the mouse.  See de-
tails below as to how to do this. 

• Note the 3 colored arrows in the 
bottom left hand corner of the 
model relate to the axes configu-
ration.  Red = X  Green = Y and 
Blue = Z. 

• Click Next 

To zoom in… 
Using the mouse, hold down the right mouse button on the 3D model while moving the cursor 
upwards.  This enlarges the view of the 3D model.  Moving the cursor down will make the 3D 
model smaller. 
 
To rotate the model… 
You can also tilt the 3D model front to back and left to right.  Using your mouse, left-click on the 
3D model.  While holding the left mouse button down, move the cursor upwards.  This tilts the 
back edge of the 3D model down.  Moving the cursor down will tilt the front edge of the 3D 
model. 

Figure 1 - Setting the Units 

Figure 2 - Imported Model 



 

 

Unit 2 QuickCAM 3D F1 Tutorial 

2.2 

    
     
3) ORIENTATE MODEL 
 
• In this section of the wizard you 

will rotate your model into the cor-
rect orientation for it to be ma-
chined. 

 
• The large red arrow indicates the 

tool cutter direction 
 
• You need to rotate the model so 

that you can machine down the 
sides of the car when it is fitted in 
the F1 fixture. 

 
• The car must be rotated so that 

the rear of the car is to the left and 
the floor is to the bottom of the 
screen as shown in Figure 4. 

 
• In this case the model has been 

rotated 90 degrees in the X axis.  
 
• Click on the X value and enter 90 
 
• Click Next 
 

Figure 3 -  Top view of car 

Figure 4 - View of Orientated Model 



 

 

2.1 

2.3 

Figure 5 - Finding maximum model width 

4) SET THE CUT DEPTH 
 
• In this page of the wizard you 

will set the depth of the model 
that you want to be machined 

 
• The blue plane is called the cut 

plane and can be moved to con-
trol the maximum depth the cut-
ter is allowed to machine to. 

 
• Click on the bottom button 

 

• Write down the  Z Cut depth 
as this is the maximum width 
of your model.  You will need 
this value latter in the tutorial. 

• Click on the Centre button and 
the blue cut plane will move to 
the centre line of the model. 

• The tool needs to cut below the 
centerline of the model so as to 
ensure the tool paths overlap 
and there is not a ridge left after 
machining. 

• Take the cut depth 4mm further 
down by clicking on the down 
arrow 4 times.  In this case set 
to –35.5  

  

 

• Click Next Figure 6 - Setting Cut Depth 

Unit 2 QuickCAM 3D F1 Tutorial 



 

 

5) SET BILLET SIZE 
 
• This page of the Wizard allows you 

to define the block size that you 
want to be able to machine. 

 
• As you will be clamping the block at 

one end with the fixture you do not 
want to include this part of the 
Balsa Blank in the Billet area. 

 
• Enter the values as shown below 
 X 210  
 Y 50 
 Z 65 
 
 
Note:  
 
• The actual size of the billet is  
      X =223mm Y=50 and Z=65.   
 
 
 
 
 
• Having entered a value of X=210 

will leave 13mm to hold the end of 
the billet. 

 
 
 
 
 
• Click Next 

Unit 2 QuickCAM 3D F1 Tutorial 

Figure 7 - Set Billet Size 

Figure 8 - Enter Billet Values 

2.4 



 

 

Unit 2 QuickCAM 3D F1 Tutorial 

2.1 

2.5 

 
6)   SET MODEL SIZE  
 
 
 
• In this page of the wizard you will 

ensure your model is sized to 
100% and that it is positioned cor-
rectly within the Billet. 

 
• The Model Dimensions will match 

the area of the model previously 
designed from the cut plane up-
wards. 

 
 
 
 
 
 
 
 
 
 
 
• Check the scale is set to 100% 
 
 
 
• Check the Z value is half the width 

of the model plus 4 
 
 
 
• Click Next 
     
  

Figure 9 - Set Model Size Window 

Figure 10 - Model Dimension Values 



 

 

Unit 2 QuickCAM 3D F1 Tutorial 

2.1 

2.6 

Figure 11- Model Position window 

7) SET MODEL POSITION 
 
• In this page of the Wizard you will 

position the model within the bil-
let.  If the model is not as wide as 
the billet you will have to center 
the model in the block by lower-
ing it below the surface of the 
billet by half the difference in the 
sizes. 

 
• In the example shown the Block 

is 65mm wide and the model 
thickness (which was noted in 
step 4) of this tutorial) was 
63mm.  As a result the model 
needs to be positioned below the 
surface of the block by 1mm on 
both sides of the car. 

 
• The Z position should be set to 

half of 65mm - Actual Model 
width (recorded in section 4)  

 
• In this case (65-63)/2=1 
 
• Example for a model 60mm wide 

the Z position would be (65-
60)/2=2.5 

 
• X Y Position should be set to 

Zero. 
 
• Click Next 
 
 
 
 
 
 
 
 

Figure 12- Model Position window 



 

 

Unit 2 QuickCAM 3D F1 Tutorial 

2.1 

2.7 

Figure 13 - Select the 1/4” Ball Nose cutter 

9) SETUP TOOLS 
 
• In this page of the wizard you 

must ensure that the 1/4” ball 
nose cutter is available. 

 
• Check if the cutter is shown in 

the list.  If so select it. 
 
• If the 1/4”  Ball nose cutter does 

not appear in the list, Select Edit.. 
 
• Go to the choose standard tool 

dropdown and select the 1/4” Ball 
nose cutter. 

 
• Select OK. 
 
• Select Next  

Figure 12 - Set Boundary window 

8) SET BOUNDARY 
 
• In this page of the Wizard we are 

setting the boundary for the tool 
travel.   

 
• To allow the tool to travel outside 

the model boundary so the tool 
tip can move down the model 
sides you have to Extend the 
Model boundary by more than 
the Diameter of the cutter. 

 
• You do not want the cutter to ma-

chine the fixture at both ends of 
the model so you only need to 
extend the Boundary in the Y 
axis.  DO NOT SELECT BILLET 
as this could cause the tool to 
collide with the fixture. 

 
• Select the Model Button 
 
• Enter an Y value of  7 
 
• Click Next 

Figure 12a-   
Boundary set to 4mm 
 



 

 

Unit 2 QuickCAM 3D F1 Tutorial 

2.1 

2.8 

Figure 14 - Machining Plans window 

Figure 15 - Machining Strategies 

10) MACHINING PLANS 

• This page of the wizard allows 
you to select the correct machin-
ing Strategy to cut your car. 

• Under the Plans menu click Add 

• You do not need to rough the 
model as the 1/4” ball cutter is 
capable of cutting 40mm deep in 
Balsa wood in one pass. 

• Select the Raster finishing plan 
from the list. 

• The other cutting plans shown 
colored grey are unavailable in 
Quick CAM 3D but can be se-
lected from Quick CAM PRO. 

• These additional Strategies al-
low more complex cutter paths 
to be created which can create a 
better finish on the model.  

• Select the Raster Finishing Plan 
by left clicking on it. 



 

 

Unit 2 QuickCAM 3D F1 Tutorial 

2.1 2.5 2.1 

2.9 

Figure 16 - Raster Finishing plan parameters 

• When you have selected the 
Raster Finishing Machining Plan 
you must make sure the follow-
ing information is selected.  

• The tool selected is the 
6.35mm—Ball Nose 1/4”. If not 
select it from the dropdown 

• The Step Over must be set to 
15% (you can decrease this 
value if you want to improve the 
quality of your model) 

• The Feedrate must be set to 
4000.  (you can reduce this if 
you have a model with fine 
wings that may be delicate) 

• The Spindle speed must be set 
to 23000 

• The Raster Angle must be set to 
90  

• Click OK 

• The toolpath will be calculated.  
This may take some time . 

 

 

 

• Once the toolpath calculation is 
complete, click Next. 

Figure 17- Toolpath Calculation window 



 

 

Unit 2 QuickCAM 3D F1 Tutorial 

2.1 2.5 2.1 

2.10 

 

 

Figure 18 - Toolpath Simulation window 

Figure 19 - Toolpath Simulation Complete 

11) TOOLPATH SIMULATION 
 
• The simulation page of the wiz-

ard will show you what your fin-
ished part will look like.  You can 
go back and change the settings 
in the machining plan then recal-
culate to see what the resulting 
tool path will look like. 

 
• Click the Play button to simulate 

the cutting action. 
 
• The slider bar can be used to 

speed up simulation. 
 
• Turbo mode updates the simula-

tion every 10 program lines. 
When Off each line of code is 
simulated. 

 
 
Play  
 
 
 Stop 
 
 
 Turbo - speeds up        
simulation 

 
  
 Pauses Program 
  
  
 Takes a snapshot of the                                           
simulated car and saves a  

 bitmap file. 
 
 
• When you are happy with your 

simulation you can continue. 
 
• Click Next to Proceed 
 
 
 



 

 

Unit 2 QuickCAM 3D F1 Tutorial 

2.1 2.5 2.1 

2.11 

Figure 20 - CNC File Output window 

12) CNC FILE OUTPUT 
 
• In this page of the Wizard we 

set the origin for the program.  
We also export the machine 
cutter path as an FNC file 

 
• As the car revolves around the 

bore for the CO2 cartridge the 
centerline of the bore is used as 
the origin. 

 
• The Bore centerline in 29mm 

above the base of the car. 
 
• Use the up arrow next to the Y 

Datum position to set the value 
to 29.00 

 
• Leave X and Z set to 0 
 
• Left mouse click on Create FNC 

file. 
 
• Select the directory where you 

want to save your CNC file.   
 
• Name your file and Save. 
 
• You have now saved the CNC 

file so you can close Quick CAM 
3D. 

 
 

* The Datum Position is where you will set the  Zero point for the Machine offsets on the CNC Ma-
chine.  In this case, it is 29 MM from the bottom of the Balsa Blank to the center of the cartridge 
hole.  If you want to machine the left side of the car, the Y value would be 21 MM, because from 
the top of the Balsa Blank to the center of the cartridge hole, it is 21 MM. If you were to machine 
the top or bottom of the car, the Y value would be 32.5 MM because the   cartridge hole is cen-
tered in the blank left to right. 



 

 

2.12 

Unit 2 QuickCAM 3D F1 Tutorial 

Figure 21 - Model Rotated to cut LHS 

13)    Editing the CNC File 
 
• You have saved the program to 

cut the Right hand Side of the 
car. 

 
• It is possible to run through 

Quick CAM again with the 
model  rotated as shown in Fig-
ure 21 to make a program for 
the Left Hand Side of the Car. 

 
• It is simpler however to edit the 

G&M code program you have 
created and add a mirror com-
mand. 

 
• The next section of the tutorial 

covers editing your program and 
then setting up the fixture and 
manufacturing the Car. 

 
• The Machine operating software 

will be either VR Milling 2 or VR 
Milling 5.  You should ask your 
instructor which version you 
have then follow the instructions 
for the version you are using.  

 
 
 
 
      
       



 

 

Manufacturing the Car 



 

 



 

 

Open the VR Milling Software 
 
• It does not matter if you are using 

VR Milling V2 or V5 at this stage.  
Your screen shots may not match 
exactly. 

 
• The default directory is in Program 

Files > Denford 
 
• Select VR Milling and the Soft-

ware will open.  There will be an 
empty Editor box open at start up. 

 
 
 
• Select File > OPEN then locate your 

saved car (FNC) file. 
 
 
• Select Open 
 
• This is the file you will manufacture 

to cut the RHS of your car. 
 
• Scroll down the program to the point 

where you can see the G91 G28 X0 
Y0 Z0 line. 

 
• Press Enter on this line and a new 

blank line will appear in the program 
under the original. 

 
• Type M71 which is the mirror Y 

about origin command. 
 
• Select the file SAVE AS command 

and save this file with your cars 
name and LHS. 

 
• This will be the file you use to cut 

the second half of the car. 
 
 

Unit 3 Machining the Car 

3.1 

VR milling with empty editor 

Edited file for LHS 

File open Window 

Creating the Left Hand Side Machine File 



 

 

Unit 3 Machining the Car 

Task 1 Setting up the Fixture 

3.2 

Note… The following tutorial will guide you through the process of setting up the F1 Fixture, setting 
the offsets, and machining the car. It has been written with the understanding that you are already 
familiar with the machine and have gone through the Quick Start Guide. If you have any questions, 
please refer to the Microrouter Compact Manual. 

1)   Before installing the fixture, make sure the 
following things are completed. 

• 1/4” Long Reach Ball Nose End Mill is in-
stalled in the Spindle. 

• VR Milling is running and you are connected 
to the machine. 

 
2)   Mounting the Fixture Base Plate.           
• Using the T Nuts and the screws, mount the 

Fixture Base Plate in the second T Slot cen-
tered on the table. Do not tighten the screws 
yet. 

 
3)   Place the F1 Fixture onto the Fixture Base 

Plate and tighten the thumb screws. 
 
4)   Aligning the Fixture. 
• Align the fixture by jogging the X axis be-

tween the two grooves located on the F1 
Fixture. When jogging the machine, the ball 
nose endmill should be centered in each of 
the grooves. Once that is done, carefully 
loosen the thumb screws and remove the 
fixture from the base plate.   

• Tighten the screws in the base plate.  
 
      * This is the most important part of the setup. 

It is critical to have the fixture aligned prop-
erly, and parallel to the T Slot Table, so take 
your time in setting this up. 

 
 

Figure 1 - The Fixture Base Plate. 

Figure 2- The F1 Fixture. 



 

 

Unit 3 Machining the Car 

Task 2 Loading the Car Blank 

3.3 

1)   Align the front of the block into the 
groove on the nose plate of the fixture 
and insert the Cartridge pin into the 
rear of the car. 

 
2) Tighten the two screws on the nose 

plate to secure the blank to the fixture. 
  
3)   Rotate the blank so the right side is 

facing up and tighten the     two thumb 
screws. 

 
 
 
 
 
 
 

Figure 3 - Billet loaded into fixture. 

Figure 4 - Nose plate and blank. 



 

 

Unit 3 Machining the Car 

Task 3 Setting the Offsets Using VR Milling V2 

3.4 

1)   In VR Milling, click on the Offset button at the 
bottom of the screen. A window similar to the 
one in Figure 5 should appear. 

 
2)   Create an offset called, F1 Car and make it 

current by right clicking on the offset and se-
lecting Make Current.  If you are unsure how 
to do this, refer to your VR Milling Manual. 

 
3)   Setting the Y offset for the right hand side 
 
• Jog the machine so the ball nose endmill is 

centered in the groove of the fixture as shown 
in Figure 6. Click on the datum point in the 
offsets window and select the default. 

 
 
 
 
4) Setting the X offset for the right hand side 
 
• Jog the machine so the center of the ball nose 

endmill is on the edge of the left side of the 
blank. Refer to Figure 7. Click on the datum 
point in the offsets window and select the de-
fault. 

 
 
 
 
 
5)   Setting the Z offset for the right hand side 
 
• Jog the machine so the ball nose endmill is 

just touching the top of the balsa blank. Click 
on the datum point next to the Z in the Work 
Piece Offset window and then click OK. 

 

Figure 6 -  Y offset position. 

Figure 5 - Offset Window 

Figure 7 -  X  Offset Position. 

If you are using VR Milling Version 2 you will set 
your offsets using the following instructions on this 
page.  If you are using VR Milling Version 5 you 
need to move on to the next page. 



 

 

Unit 3 Machining the Car 

Task 3 Setting the Offsets Using VR Milling V5 

3.5 

1) In VR Milling V5, click on the Offset button at 
the bottom of the screen. A window similar to 
the one in Figure 8 should appear. 

 
 
 
2)   Create an offset called, F1 Car and Activate it 

current by right clicking on the offset and se-
lecting Activate.  If you are unsure how to do 
this, refer to your VR Milling Manual. 

 
3)   Setting the Y offset for the right hand side 
 
• Jog the machine so the ball nose endmill is 

centered in the groove of the fixture as shown 
in Figure 9. Click on the Y datum button in the 
offsets window. Your Y Offset is now set. 

 
 
 
 
 
4)  Setting the X offset for the right hand side 
 
• Jog the machine so the center of the ball nose 

endmill is on the edge of the left side of the 
blank. Refer to Figure 10. Click on the X  

 datum button in the offsets window. Your X 
offset is now set. 

 
 
 
 
 
5)   Setting the Z offset for the right hand side 
 
• Jog the machine so the ball nose endmill is 

just touching the top of the balsa blank. Click 
on the Z datum button in the offsets window.  
Your Z offset is now set. 

 

Figure 9 -  Y offset position. 

Figure 8 - Offset Window 

Figure 10 -  X  Offset Position. 



 

 

Unit 3 Machining the Car 
Task 4 Executing the Program 

3.6 

1)   Make sure the following tasks are complete: 
• Blank is rotated in the fixture as shown in Fig-

ure 11. 
• VR Milling has the RHS car file loaded. 
• F1CAR Offset is active. 
• Machine is in Home Position 
• Go to File, Source, and Left click on File.  

This will give you better performance when 
machining large FNC files. 

 
*  To make sure that your balsa blank is square 

to the fixture, use a steel square before tight-
ening the thumb screws. Figure 12. 

 
 
2)   Select Auto Mode 
• Make sure Turbo button is checked.  
• Click Run 
 
3) Once you have machined the right hand side, 

loosen the thumb screws on the fixture base 
and remove the fixture. 
 

4)   You will now machine the left hand side of the 
car. 

• Rotate the blank 180 degrees and place the 
Fixture back in the Fixture Base making sure 
the thumb screws are tight. 

• Load the LHS file that was created into VR 
Milling. 

• You will be using the same offset that was 
used for the RHS.  

 
6)   Select Auto Mode  
• Click Run 
  
 
 

Figure 11 -   Right Hand Side Position 

Figure 12 -   Square Alignment 



 

 

Unit 3 Machining the Car 
Task 5 Axle Holes 

3.7 

1) Place the machined F1 Car on the Drill-
ing fixture as shown in Figure 13. 

 
2)  Drill the Axle holes using the Drill Press. 
 
 

Figure 13 -   Axle Drilling Fixture 

Figure 14 -   Drilling the Axle Holes 



 

 

Unit 3 Machining the Car 
Reference Section 

3.8 

 
Q: What do I do when there is a ridge down the center of the blank? 
 
A: It is possible that there is going to be a small ridge down the center.  However, if it is greater than 

a millimeter, you will have to change your Y offset.  
• If the Right Hand Side of the car is higher than the left, subtract half the difference of the ridge 

from your Y offset value. 
• If the Left Hand Side of the car is higher than the right, add half the difference of the ridge to your 

Y offset value. 
 
 


